- 
                            
                                
                                    
                                        
                                                                                            Update Scheduled 
                                                                                     We have located some bugs on mobile version and we will update and the latest pages.
 20:41, Oct 10 UTC
 
- 
                            
                                
                                    
                                        
                                                                                            Update 
                                                                                     We are starting with the fix update
 20:42, Oct 10 UTC
 
- 
                            
                                
                                    
                                        
                                                                                            Update Completed 
                                                                                     All the bugs have been completed
 16:47, Oct 12 UTC
 
 
             
			 Back to current status