Dynamic pages inaccessible

February 10, Wed
Affected Service: Website Media Server
  • Identified
    All the dynamic pages on the website https://ChangemakerZ.org including the staff bio pages and articles/interview pages are inaccessible. Wix is working on a fix

    Error code:keifbeie248js127jkk_l

    12:08, Feb 10 UTC
  • Resolved
    The problem has been resolved

    12:11, Feb 10 UTC
Back to current status