"Not Secure" signature

December 03, Thu
Affected Service: Website Emails Server
  • Monitoring
    The HTTPS certificate is still disabled after the completion of the maintenance script. We will monitor the case for the next 48 hours.

    14:45, Dec 03 UTC
  • Resolved
    The protocol has been re-established and it is functional

    16:43, Dec 03 UTC
Back to current status