Unauthorized user sends email pretending the CEO

January 15, Fri
Affected Service: Emails Server
  • Identified
    We have received reports from our staff that there is an unauthorized person that sends emails pretending our CEO. We are evaluating how and why this is happening. We still don’t know if this person is using our emails systems.

    18:16, Jan 14 UTC
  • Fixing
    Our systems have bannister the sender before there a serious damage or a leak through our professional email provider. The sender is considered to be a bot that auto selected email address that doesn’t really exist like on our network under changemakerz.org (explained on discord channel).

    18:34, Jan 14 UTC
  • Monitoring
    I temporary fixed has been implemented and we are monitoring the results.

    We have enabled CDN security and extra security for all staff accounts. You may not receive emails for the next 2 hours while we are scanning the system for threads.

    18:39, Jan 14 UTC
  • Resolved
    The scanning process has been completed

    18:09, Jan 15 UTC
Back to current status