Update website’s menu

September 12, Sat
Affected Service: Website
  • Update Scheduled
    We are goin to change the x and y outputs in order to be compatible with iPads

    21:58, Sep 12 UTC
  • Update Completed
    We finished with this update

    21:59, Sep 12 UTC
Back to current status