Emails deliverability problem

February 01, Mon
Affected Service: Emails Server
  • Identified
    We have identified a delay in the processing of sending and receiving through the information system network of ChangemakerZ. We are implementing a fix in the system. You may experience error codes 503, 504, 101, or 111

    18:10, Jan 15 UTC
  • Resolved
    We have enabled extra security elements for professional accounts. CheckingMail service has been enabled for the email addresses. You can learn more at https://madebyvasilis.site/email

    10:54, Feb 01 UTC
Back to current status