Website Maintenance

December 03, Thu
Affected Service: Website
  • Update Scheduled
    We have to perform some maintenance tasks for this website

    10:24, Nov 27 UTC
  • Update
    Propagation process started

    00:01, Nov 28 UTC
  • Update in progress
    Propagation process has been completed and the website will be available in the next 24 hours after the DNS updates have been completed

    10:49, Dec 03 UTC
  • Update Completed
    Website maintenance has been completed. Now we run under Cloudflare network

    14:44, Dec 03 UTC
Back to current status