-
Investigating
We found that emails sent to it@changemakerz.org receives a MAILER DAEMON response says that this email couldn’t get delivered. Our team is investigating the issue.
08:14, Dec 25 UTC
-
Identified
Our IT department located the issue. There is a bug on DMARC policy. We are implementing a fix right now.
08:16, Dec 25 UTC
-
Monitoring
A fix has been implemented and we are monitoring the behavior
08:22, Dec 25 UTC
-
Resolved
The issue has been resolved
08:29, Dec 25 UTC
Back to current status