Saloni Nayak bio update

November 10, Tue
Affected Service: Website
  • Update Scheduled
    We are going to update the bio for Saloni Nayak page under the main team page

    18:50, Nov 10 UTC
  • Update
    The update has been started

    20:49, Nov 10 UTC
  • Update Completed
    The database has been updated. Some bugs were fixed in the team page

    20:56, Nov 10 UTC
Back to current status