Loading elements and submissions page - Update

October 18, Sun
Affected Service: Website
  • Update Scheduled
    We have scheduled an update for your website today

    07:04, Oct 17 UTC
  • Update in progress
    Your website’s update has been started

    07:05, Oct 17 UTC
  • Update Completed
    We have finished with this update. Some bugs were fixed as well

    10:34, Oct 18 UTC
Back to current status